An attempt to install Mac in my Dell D430

Yesterday, I suddenly felt like installing my Dell D430 with Mac. I searched for iATKOS 10.5.4 given to me by my colleague ages ago & installed it into the Dell. All using the default setup. In one attempt the Mac booted up very nicely! Wow!

However I got two major problems, the network, both LAN & WiFi are not functioning. So did the sound. I managed to installed necessary kext (Sigmatel 9200) using AppleHDA Patcher 1.2 & now the notebook can sing nicely. I am now desperately searching for the kext for my network devices in Dell D430. Anyone?

Update:

OK, I found one solution. This is for my WiFi driver PROSet/Wireless 3945a/b/g. It’s from ocix33 at http://www.hackint0sh.org/forum/f180/61609.htm:

I’ve managed to make mine working, but there’s always a BUT.

Card is recognized and is making search for wireless networks available and shows them, BUT these drivers only conect to networks WITHOUT security. This means that only free wireless’s will work.

How to install:

Go to http://code.google.com/p/iwidarwin/

and download

PROSet/Wireless 3945a/b/g OS X 10.5 SVN latest

now, on your MAC, do the following:

Install the .pkg and when it tells you to press restart DON’T DO IT right away. Wait a minute because Leopard will recognize the card and ask you to go to network preferences. When that happens, press APPLY in network preferences.

Now you can reboot.

DON’T TRY TO OPEN THE UTILITY TO WORK WITH THE WIRELESS CARD YET.

After reboot, go to disk manager and make a permissions repair action. After that, reboot again.

Now you can go to Applications folder and start the NetworkSelector app.

Enjoy your wireless device.

BTW the Disk Manager mentioned in the message above is actually Disk Utility available in your Applications/ Utilities folder. This solution didn’t work for me tho’ :(

3 Comments

  1. remi June 21, 2009 at 9:11 am #

    rajinnya lah buat buat benda alah camnih….saya malas betull….bila dah lama meninggalkan system engineering works nih, rasa lembab jek nak explore benda2 baru niehhh.

    arrrghhhhh

  2. black1282 June 30, 2009 at 4:49 pm #

    check out this page on the insanelymac forum, it is dedicated to the dell d430

    http://www.insanelymac.com/forum/index.php?showtopic=150935&pid=1066455&mode=threaded&start=#entry1066455

    good luck!

  3. neo August 20, 2009 at 1:40 pm #

    i’ve got mine working, with triple boot kallyway+kubuntu+winxp on delld430.

    Yup i didnt get wifi work on hackintosh too. Will try with your suggestion. thanks.

Post a Comment

Your email is never published nor shared. Required fields are marked *

*
*